ENVI/IDL 최신 버전의 지원 플랫폼

최근 ENVI 5.6, IDL 8.8을 설치하며 가장 놀라는 점은, 이들의 최신 버전이 Redhat(CentOS) 6 계열을 지원하지 않는다는 것입니다. 최근에 배포된 Redhat 6.10도 지원하지 않기 때문에, 리눅스 커널 2.x 는 향후 버전에서 더 이상 지원하지 않는다는 의미입니다. Redhat 6.x는 안정적이며 여전히 현역에서 활약하는 운영체제라는 점에서 아쉽기는 하지만, 지원 플랫폼의 단순화는 상용소프트웨어의 전략에서 매우 중요한 부분이기도 합니다. …

Continue reading ‘ENVI/IDL 최신 버전의 지원 플랫폼’ »

ENVI 5.6 Linux용 설치 경험(작성 중 : 2020. 08. 23.)

Ubuntu 20.04.1 LTS에 ENVI 5.6을 설치하여 보았습니다. IDL 8.8도 같은 방법으로 설치합니다. ENVI 5.6은 Linux Kernel 2.x 버전을 지원하지 않습니다. Kernel 2.x를 사용하는 대표적인 버전이 Redhat 6.x 계열(CentOS 6.x 계열)입니다. Redhat6.x 계열은 2018년에 6.10 이 출시된 OS로 여전히 현역이지만, 안타깝게도 IDL 8.8, ENVI 5.6은 Kernel 3.10.0 이상부터 지원합니다(Redhat 7 계열 이후입니다). 기본설치 늘 그렇듯이 envi56-linux.tar.gz …

Continue reading ‘ENVI 5.6 Linux용 설치 경험(작성 중 : 2020. 08. 23.)’ »

Linux libXp.so.6

리눅스의 libXp 라이브러리는 프린터로 그림을 출력하기 위한 라이브러리라고 합니다. 저도 그렇게 나와 있으니 그런가 보다 합니다. 어쨌든, Linux용 IDL을 설치하고 나서, IDL을 처음 실행해 보려고 할 때, 흔히 만날 수 있는 메시지가 libXp가 없다는 에러 메시지입니다. yi@stella:~$ idl /usr/local/exelis/idl85/bin/bin.linux.x86_64/idl: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory …

Continue reading ‘Linux libXp.so.6’ »

IDLwave (Emacs IDL 개발 환경)

IDLWave 라는 것이 있었습니다. Emacs 라는 개발환경에 구축한 IDL 개발환경입니다. Emacs는 VI 와 더불어 유닉스 계열 에디터의 양대 산맥이죠. 두 에디터에 대한 위키피디아를 보니 두 가지 모두 1976년부터 만들어진 에디터라고 하네요. 와우… 40년입니다. IDL 개발환경(IDLDE)이 IDL 7.0부터 eclipse 기반으로 완전히 바뀌었습니다. 이 이후로는 윈도우든, 리눅스든, 맥킨토시든 같은 조건의 개발환경을 사용하고 있습니다. 그런데 그 이전에는 수준이 …

Continue reading ‘IDLwave (Emacs IDL 개발 환경)’ »

IDL 8.3 hotfix

최신 버전의 Linux(Fedora 20 or openSUSE 13.1)를 Haswell 계열의 CPU에서 사용하시는 IDL 유저분들에게 필요한 hotfix가 배포되었습니다. hotfix 설치없이 사용하면 Workbench에서 충돌이 일어날 수 있다고 하네요. 다음의 링크에서 내용을 확인하실 수 있습니다. IDL8.3 hotfix 안내 hotfix의 다운로드는 역시 ExelisVIS 홈페이지 내 “My Account”에서 하실 수 있습니다. 고로 회원가입도 반드시 필요합니다. 이미 IDL 8.3의 설치가 되어 있는 …

Continue reading ‘IDL 8.3 hotfix’ »

Ubuntu에서 lmgrd가 실행되지 않아요.

IDL8.3 부터는 32bit 기반의 Linux에서는 사용할 수 없습니다. 64bit 리눅스만 지원하거든요. 그래서인지 lmgrd, lmutil 등의 라이센스 서비스 관련 실행 프로그램들도 모두 64bit 용으로 제공됩니다. 원인이 여기에 있는지는 솔직히 잘 모르겠습니다. 그동안 사용하던 CentOS (64bit)에서는 잘 실행이 되는데, 새로 설치한 Ubuntu 13.10 (64bit)에서는 IDL 8.3의 lmgrd가 실행이 안되는 것입니다. 다음과 같은 메시지를 내며 멈춰 버리는 것입니다. …

Continue reading ‘Ubuntu에서 lmgrd가 실행되지 않아요.’ »